summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-13 12:34:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:06 +0300
commit9078d0298d646427a29069bffbdaada0d85d908d (patch)
treed4aa7bf6e665f3b768e0a5cf6fc1886567fbf252 /gnu
parent0fa584fe5c741a6fbbc8161b1a720ccafc1a7e93 (diff)
downloadguix-9078d0298d646427a29069bffbdaada0d85d908d.tar.gz
gnu: Add rust-rustc-rayon-core-0.5.
* gnu/packages/crates-io.scm (rust-rustc-rayon-core-0.5): New variable.
(rust-rustc-rayon-core-0.4): Inherit from rust-rustc-rayon-core-0.5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm36
1 files changed, 30 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 787e6f2ac4..12175d3f64 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -54109,25 +54109,29 @@ way into rayon proper at some point.  In general, if you are not rustc, you
 should be using the real rayon crate, not rustc-rayon.")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-rustc-rayon-core-0.4
+(define-public rust-rustc-rayon-core-0.5
   (package
     (name "rust-rustc-rayon-core")
-    (version "0.4.1")
+    (version "0.5.0")
     (source (origin
               (method url-fetch)
               (uri (crate-uri "rustc-rayon-core" version))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0c4cf58056ya3282c24bnyq39cwm1rd1m96lymfbb6yvl12929h2"))))
+                "0zqbr87x58j2g9rgm2lc0254b6yqabb41jvddw99qd8fy2m8srk7"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:tests? #f   ;XXX cannot find rayon_core?
-       #:cargo-inputs
+     `(#:cargo-inputs
        (("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
         ("rust-crossbeam-deque" ,rust-crossbeam-deque-0.8)
         ("rust-crossbeam-utils" ,rust-crossbeam-utils-0.8)
-        ("rust-num-cpus" ,rust-num-cpus-1))))
+        ("rust-num-cpus" ,rust-num-cpus-1))
+       #:cargo-development-inputs
+       (("rust-libc" ,rust-libc-0.2)
+        ("rust-rand" ,rust-rand-0.8)
+        ("rust-rand-xorshift" ,rust-rand-xorshift-0.3)
+        ("rust-scoped-tls" ,rust-scoped-tls-1))))
     (home-page "https://github.com/rust-lang/rustc-rayon")
     (synopsis "Core APIs for Rayon - fork for rustc")
     (description
@@ -54137,6 +54141,26 @@ Rayon-core represents the \"core, stable\" APIs of Rayon: join, scope, and so
 forth, as well as the ability to create custom thread-pools with ThreadPool.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-rustc-rayon-core-0.4
+  (package
+    (inherit rust-rustc-rayon-core-0.5)
+    (name "rust-rustc-rayon-core")
+    (version "0.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "rustc-rayon-core" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0c4cf58056ya3282c24bnyq39cwm1rd1m96lymfbb6yvl12929h2"))))
+    (arguments
+     `(#:tests? #f   ;XXX cannot find rayon_core?
+       #:cargo-inputs
+       (("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
+        ("rust-crossbeam-deque" ,rust-crossbeam-deque-0.8)
+        ("rust-crossbeam-utils" ,rust-crossbeam-utils-0.8)
+        ("rust-num-cpus" ,rust-num-cpus-1))))))
+
 (define-public rust-rustc-serialize-0.3
   (package
     (name "rust-rustc-serialize")