summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-29 15:04:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-29 15:27:19 +0100
commit90be4f8319c0a3f5a1407a752eff1ec3487728ab (patch)
treeaa74d9724062fbd550f9326ef422d4983a0c181c /gnu
parent36b993cd5b7088513d771fc2140c56327555c89b (diff)
downloadguix-90be4f8319c0a3f5a1407a752eff1ec3487728ab.tar.gz
gnu: Add r-clock.
* gnu/packages/cran.scm (r-clock): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ad0657ef3b..af3327ae9b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1076,6 +1076,32 @@ size and can be easily tested locally before being sent to a remote.")
 the system clipboards.")
     (license license:gpl3)))
 
+(define-public r-clock
+  (package
+    (name "r-clock")
+    (version "0.6.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "clock" version))
+              (sha256
+               (base32
+                "00hp7k24d599dzkzhhb6xky2pj6xaggdfwgviyb3i592v1gkh37q"))))
+    (properties `((upstream-name . "clock")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-cpp11 r-rlang r-tzdb r-vctrs))
+    (native-inputs (list r-knitr))
+    (home-page "https://clock.r-lib.org")
+    (synopsis "Date-Time types and tools")
+    (description
+     "This package provides a comprehensive library for date-time
+manipulations using a new family of orthogonal date-time
+classes (durations, time points, zoned-times, and calendars) that
+partition responsibilities so that the complexities of time zones are
+only considered when they are really needed.  Capabilities include:
+date-time parsing, formatting, arithmetic, extraction and updating of
+components, and rounding.")
+    (license license:expat)))
+
 (define-public r-clvalid
   (package
     (name "r-clvalid")