summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-01-07 14:14:50 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-07 14:41:01 +0100
commit915c6bf60cd6bd69fafc3acc69fac1242c3d96a3 (patch)
tree1fd9d2ce43bca2ea32bffba36af7e232de44db10 /gnu
parent6fd5a80dbe7013fc37aa1228051d02b42ee76527 (diff)
downloadguix-915c6bf60cd6bd69fafc3acc69fac1242c3d96a3.tar.gz
gnu: python2-fastlmm: Move to machine-learning.scm.
This is a step towards removing OCaml modules from the closure
of (gnu packages python).

* gnu/packages/python.scm (python2-fastlmm): Move to...
* gnu/packages/machine-learning.scm (python2-fastlmm): ... here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm34
-rw-r--r--gnu/packages/python.scm35
2 files changed, 34 insertions, 35 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 084e62cca4..39ac7cad7c 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -873,3 +873,37 @@ the following advantages:
 such as online, hashing, allreduce, reductions, learning2search, active, and
 interactive learning.")
     (license license:bsd-3)))
+
+(define-public python2-fastlmm
+  (package
+    (name "python2-fastlmm")
+    (version "0.2.21")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "fastlmm" version ".zip"))
+       (sha256
+        (base32
+         "1q8c34rpmwkfy3r4d5172pzdkpfryj561897z9r3x22gq7813x1m"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2)) ; only Python 2.7 is supported
+    (propagated-inputs
+     `(("python2-numpy" ,python2-numpy)
+       ("python2-scipy" ,python2-scipy)
+       ("python2-matplotlib" ,python2-matplotlib)
+       ("python2-pandas" ,python2-pandas)
+       ("python2-scikit-learn" ,python2-scikit-learn)
+       ("python2-pysnptools" ,python2-pysnptools)))
+    (native-inputs
+     `(("unzip" ,unzip)
+       ("python2-cython" ,python2-cython)
+       ("python2-mock" ,python2-mock)
+       ("python2-nose" ,python2-nose)))
+    (home-page "http://research.microsoft.com/en-us/um/redmond/projects/mscompbio/fastlmm/")
+    (synopsis "Perform genome-wide association studies on large data sets")
+    (description
+     "FaST-LMM, which stands for Factored Spectrally Transformed Linear Mixed
+Models, is a program for performing both single-SNP and SNP-set genome-wide
+association studies (GWAS) on extremely large data sets.")
+    (license license:asl2.0)))
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2fa510067b..a1a9b44dc4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -103,7 +103,6 @@
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages llvm)
-  #:use-module (gnu packages machine-learning)
   #:use-module (gnu packages man)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages multiprecision)
@@ -3228,40 +3227,6 @@ color scales, and color space conversion easy.  It has support for:
 (define-public python2-spectra
   (package-with-python2 python-spectra))
 
-(define-public python2-fastlmm
-  (package
-    (name "python2-fastlmm")
-    (version "0.2.21")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "fastlmm" version ".zip"))
-       (sha256
-        (base32
-         "1q8c34rpmwkfy3r4d5172pzdkpfryj561897z9r3x22gq7813x1m"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:python ,python-2)) ; only Python 2.7 is supported
-    (propagated-inputs
-     `(("python2-numpy" ,python2-numpy)
-       ("python2-scipy" ,python2-scipy)
-       ("python2-matplotlib" ,python2-matplotlib)
-       ("python2-pandas" ,python2-pandas)
-       ("python2-scikit-learn" ,python2-scikit-learn)
-       ("python2-pysnptools" ,python2-pysnptools)))
-    (native-inputs
-     `(("unzip" ,unzip)
-       ("python2-cython" ,python2-cython)
-       ("python2-mock" ,python2-mock)
-       ("python2-nose" ,python2-nose)))
-    (home-page "http://research.microsoft.com/en-us/um/redmond/projects/mscompbio/fastlmm/")
-    (synopsis "Perform genome-wide association studies on large data sets")
-    (description
-     "FaST-LMM, which stands for Factored Spectrally Transformed Linear Mixed
-Models, is a program for performing both single-SNP and SNP-set genome-wide
-association studies (GWAS) on extremely large data sets.")
-    (license license:asl2.0)))
-
 (define-public python-numpy-documentation
   (package
     (name "python-numpy-documentation")