summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 15:36:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:14 -0400
commit9165283a1cdd087d76b70563315eb59e8a608704 (patch)
treef97f285433229a682704784a655444bf32c1528b /gnu
parenta683c74e9a1d7eb41714625f21da5afcf36f549d (diff)
downloadguix-9165283a1cdd087d76b70563315eb59e8a608704.tar.gz
gnu: Remove python2-setuptools-scm.
* gnu/packages/python-xyz.scm (python2-setuptools-scm): Delete variable.
(python-lfdfiles)[properties]: Delete field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 1 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83200aa813..cd5bf33981 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7713,21 +7713,7 @@ child application and control it as if a human were typing commands.")
      "Setuptools_scm handles managing your Python package versions in
 @dfn{software configuration management} (SCM) metadata instead of declaring
 them as the version argument or in a SCM managed file.")
-    (license license:expat)
-    (properties `((python2-variant . ,(delay python2-setuptools-scm))))))
-
-(define-public python2-setuptools-scm
-  (let ((base (package-with-python2
-               (strip-python2-variant python-setuptools-scm))))
-    (package/inherit base
-      (version "5.0.2")                  ;no python 2 support in version 6
-      (source (origin
-                (method url-fetch)
-                (uri (pypi-uri "setuptools_scm" version))
-                (sha256
-                 (base32
-                  "1j75i8avp9fhrkpbabsa8vyvbi49kmxlq6l10xir9qs96kfwx843"))))
-      (propagated-inputs '()))))
+    (license license:expat)))
 
 (define-public python-sexpdata
   (package