summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2017-08-04 20:52:16 +0800
committerArun Isaac <arunisaac@systemreboot.net>2017-08-05 18:58:58 +0530
commit91d94e28ec30d72e1e6a7d0ff8af49656c3f1d7e (patch)
tree2481042dc1943cc297348bc09b891106bad1da1f /gnu
parente78e38a4bb341b33f91afa7a8efa421be2d74905 (diff)
downloadguix-91d94e28ec30d72e1e6a7d0ff8af49656c3f1d7e.tar.gz
gnu: emacs-exwm-x: Do not set DISPLAY.
* gnu/packages/emacs.scm (emacs-exwm-x): Do not set DISPLAY. The issue has
been fixed upstream in exwm-0.15.

Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm3
1 files changed, 0 insertions, 3 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9beb7ae62e..4aa713346f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4767,12 +4767,9 @@ other operations.")
                      TryExec=~@*~a~@
                      Type=Application~%" ,name ,synopsis exwm-executable)))
                ;; Add a shell wrapper to bin
-               ;; Set DISPLAY variable to work around
-               ;; https://github.com/ch11ng/exwm/issues/213
                (with-output-to-file exwm-executable
                  (lambda _
                    (format #t "#!~a ~@
-                     export DISPLAY=:0 ~@
                      ~a +SI:localuser:$USER ~@
                      exec ~a --exit-with-session ~a \"$@\" --eval '~s' ~%"
                            (string-append (assoc-ref inputs "bash") "/bin/sh")