summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2020-12-08 21:45:56 +0800
committer宋文武 <iyzsong@member.fsf.org>2020-12-11 21:21:51 +0800
commit91e35e32a4938e0e37499c64fa8ed3e7cf51dce3 (patch)
tree327f77ea576e4626f35f53e2e4ae0546b8a2c64e /gnu
parent2639a99cf31e3ce2970645badf11f15679c893b5 (diff)
downloadguix-91e35e32a4938e0e37499c64fa8ed3e7cf51dce3.tar.gz
gnu: fcitx5-chinese-addons: Remove stale build steps.
* gnu/packages/fcitx5.scm (fcitx5-chinese-addons)[arguments]
<configure-flags>: Remove it.
<phases>: Remove phase 'patch-install-prefix'.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fcitx5.scm17
1 files changed, 1 insertions, 16 deletions
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 431aeceb02..ed0d928fc7 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -293,23 +293,8 @@ for Qt based application.")
         (base32 "0mf91gzwzhfci0jn6g3l516xjw8r4v40ginnbl70h1zx6vr24rfp"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags
-       (list
-        (string-append "-DFEM_INCLUDE_INSTALL_DIR=" %output "/include")
-        (string-append "-DFEM_LIB_INSTALL_DIR=" %output "/lib"))
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
-         (add-before 'configure 'patch-install-prefix
-           (lambda* (#:key outputs #:allow-other-keys)
-             (for-each
-              (lambda (x)
-                (format #t "patch-install-prefix: Fixing install prefix in ~a~%"
-                        x)
-                (substitute* x
-                  (("\\$\\{FCITX_INSTALL_PKGDATADIR\\}")
-                   (string-append (assoc-ref outputs "out")
-                                  "/share/fcitx5"))))
-              (find-files "." "CMakeLists\\.txt$"))))
          (add-before 'configure 'split-outputs
            ;; Build with GUI supports requires Qt and increase package closure
            ;; by 800M on x86_64, so place it under another output.