summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-11-09 11:08:54 +0100
committerAndreas Enge <andreas@enge.fr>2014-11-09 11:09:12 +0100
commit922ea80683fa9ba5cc91818d2e2679b5c6c1fa6a (patch)
tree4471654980274c83de6896decf4e911f53757f35 /gnu
parentb138ec947ad10096489d6a6b2b30f992784797c4 (diff)
downloadguix-922ea80683fa9ba5cc91818d2e2679b5c6c1fa6a.tar.gz
gnu: Add nspr.
* gnu/packages/polkit.scm (nspr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/polkit.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index de2cefeb6b..6f143a6c7f 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -62,3 +62,36 @@
     (description "SpiderMonkey is Mozilla's JavaScript engine written
 in C/C++.")
     (license mpl2.0))) ; and others for some files
+
+(define-public nspr
+  (package
+    (name "nspr")
+    (version "4.10.7")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "https://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v"
+                   version "/src/nspr-" version ".tar.gz"))
+             (sha256
+              (base32
+               "0f1ri51yzjikigf6z31g03cdv6sgi9gw2c3vvv39psk3m37zb6iq"))))
+    (build-system gnu-build-system)
+    (native-inputs
+      `(("perl", perl)))
+    (arguments
+      `(#:tests? #f ; no check target
+        #:configure-flags
+        `("--enable-64bit")
+        #:phases
+          (alist-cons-before
+           'configure 'chdir
+           (lambda _
+             (chdir "nspr"))
+            %standard-phases)))
+    (home-page
+     "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR")
+    (synopsis "Netscape API for system level and libc-like functions")
+    (description "Netscape Portable Runtime (NSPR) provides a
+platform-neutral API for system level and libc-like functions.  It is used
+in the Mozilla clients.")
+    (license mpl2.0)))