summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 12:53:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 13:17:52 +0100
commit925fcdbb7943f04e1f0a8ac79c236d3543a9945b (patch)
tree9e0daf12e66b0ed01c7d3f10fa454ba0adab8512 /gnu
parent251e08301a514fa035feb17fbb0173f9a0914015 (diff)
downloadguix-925fcdbb7943f04e1f0a8ac79c236d3543a9945b.tar.gz
gnu: Add r-mast.
* gnu/packages/bioconductor.scm (r-mast): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index adc0e846d2..782b769225 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1932,3 +1932,36 @@ performance metrics for evaluation of ranking and binary
 classification (assignment) methods.  It also contains a Shiny application for
 interactive exploration of results.")
     (license license:gpl2+)))
+
+(define-public r-mast
+  (package
+    (name "r-mast")
+    (version "1.8.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "MAST" version))
+       (sha256
+        (base32
+         "0rhx655dza0m6yg9jcfz2nmxqahvxx2l91kqgyp7qai0bzz9d9ix"))))
+    (properties `((upstream-name . "MAST")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-abind" ,r-abind)
+       ("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-data-table" ,r-data-table)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-plyr" ,r-plyr)
+       ("r-progress" ,r-progress)
+       ("r-reshape2" ,r-reshape2)
+       ("r-s4vectors" ,r-s4vectors)
+       ("r-singlecellexperiment" ,r-singlecellexperiment)
+       ("r-stringr" ,r-stringr)
+       ("r-summarizedexperiment" ,r-summarizedexperiment)))
+    (home-page "https://github.com/RGLab/MAST/")
+    (synopsis "Model-based analysis of single cell transcriptomics")
+    (description
+     "This package provides methods and models for handling zero-inflated
+single cell assay data.")
+    (license license:gpl2+)))