summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 23:46:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:54 +0200
commit92f820efca7d83248dc20cb1b827d2fb878ebee0 (patch)
tree5f34da6e4933f20edc36c0e676a8eb54777a8a48 /gnu
parent29b903133e7709230010ef65e2b98a1154baa8a1 (diff)
downloadguix-92f820efca7d83248dc20cb1b827d2fb878ebee0.tar.gz
gnu: texlive-gettitlestring: Refresh package definition.
* gnu/packages/tex.scm (texlive-gettitlestring): Remove SIMPLE-TEXLIVE-PACKAGE
call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 17 insertions, 21 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7d0ea3291c..c74377140c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9595,29 +9595,25 @@ modifiers; some purely expandable numerics.")
     (license license:lppl)))
 
 (define-public texlive-gettitlestring
-  (let ((template (simple-texlive-package
-                   "texlive-gettitlestring"
-                   (list "doc/latex/gettitlestring/"
-                         "source/latex/gettitlestring/"
-                         "tex/generic/gettitlestring/")
-                   (base32
-                    "1vbvmwrpsvy37gbwdmsqbbsicjiww3i0bh1yqnb75jiya9an0sjb"))))
-    (package
-      (inherit template)
-      (outputs '("out" "doc"))
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ '())
-          "generic/gettitlestring")
-         ((#:build-targets _ '())
-          #~(list "gettitlestring.dtx"))))
-      (home-page "https://www.ctan.org/pkg/gettitlestring")
-      (synopsis "Clean up title references")
-      (description
-       "This package provides commands for cleaning up the title string
+  (package
+    (name "texlive-gettitlestring")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/gettitlestring/"
+                   "source/latex/gettitlestring/"
+                   "tex/generic/gettitlestring/")
+             (base32
+              "1vbvmwrpsvy37gbwdmsqbbsicjiww3i0bh1yqnb75jiya9an0sjb")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/gettitlestring")
+    (synopsis "Clean up title references")
+    (description
+     "This package provides commands for cleaning up the title string
 (such as removing @code{\\label} commands) for packages that typeset such
 strings.")
-      (license license:lppl1.3c+))))
+    (license license:lppl1.3c+)))
 
 (define-deprecated-package texlive-generic-gettitlestring texlive-gettitlestring)