summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-11-16 10:46:28 +0100
committerMathieu Othacehe <othacehe@gnu.org>2020-11-25 14:03:30 +0100
commit933ddba223178fc2e530d5c9e3be1dd50a64ee95 (patch)
tree1fe10b95ad39ebd3ac84127770ff2578214f60f4 /gnu
parent7f1d093eae5f9dbb48b3760a7f108d30dc592af3 (diff)
downloadguix-933ddba223178fc2e530d5c9e3be1dd50a64ee95.tar.gz
gnu: gst-plugins-bad: Enable webrtc module.
* gnu/packages/gstreamer.scm (gst-plugins-bad): Enable webrtc module.
[inputs]: Add libnice and webrtc-audio-processing.
[arguments]: Add substitution of failing tests.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gstreamer.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index a317170379..738e881d55 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -9,6 +9,7 @@
 ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -671,8 +672,9 @@ model to base your own plug-in on, here it is.")
            (lambda _
              ;; FIXME: Why is this failing.
              (substitute* "tests/check/meson.build"
-               ((".*elements/dash_mpd\\.c.*")
-                ""))
+               ((".*elements/dash_mpd\\.c.*") "")
+               ((".*elements/curlhttpsrc\\.c.*") "")
+               ((".*elements/webrtcbin\\.c.*") ""))
              #t)))))
     (propagated-inputs
      `(("gst-plugins-base" ,gst-plugins-base)))
@@ -702,6 +704,7 @@ model to base your own plug-in on, here it is.")
        ("libgudev" ,libgudev)
        ("libkate" ,libkate)
        ("libmodplug" ,libmodplug)
+       ("libnice" ,libnice)
        ("librsvg" ,librsvg)
        ("libsndfile" ,libsndfile)
        ("libsrtp" ,libsrtp)
@@ -726,6 +729,7 @@ model to base your own plug-in on, here it is.")
        ;; GStreamer is not yet compatible with srt > 1.4.1.
        ("srt" ,srt-1.4.1)
        ("x265" ,x265)
+       ("webrtc-audio-processing" ,webrtc-audio-processing)
        ("wayland" ,wayland)))
     (home-page "https://gstreamer.freedesktop.org/")
     (synopsis "Plugins for the GStreamer multimedia library")