summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2023-11-13 12:34:43 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-11-13 14:46:51 +0100
commit951a1433f38a7cffa4cbcb4065c27494c300f2fa (patch)
treecce54b5e2385f0fe0fc936c1f77e8c5b4eb2447e /gnu
parent77386bdbfe6b0c649c05ab37f08051d1ab3e5074 (diff)
downloadguix-951a1433f38a7cffa4cbcb4065c27494c300f2fa.tar.gz
gnu: Add r-illuminahumanmethylationepicmanifest.
* gnu/packages/bioinformatics.scm (r-illuminahumanmethylationepicmanifest): New variable.

Change-Id: I9635033ed5e7e44ecfaff76cd002379582900686
Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7feea35d74..a414a58382 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15657,6 +15657,41 @@ analysing cytometry data in R.")
 spatial single-cell expression data.")
       (license license:expat))))
 
+;; Variant of r-illuminahumanmethylationepicmanifest in the
+;; (gnu packages bioconductor) module.
+(define-public r-illuminahumanmethylationepicmanifest-latest
+  (let ((commit "a9ffbad36f5e496ece6c4c37b80e2f4f7e02d0c3")
+        (revision "1"))
+    (package
+      (name "r-illuminahumanmethylationepicmanifest")
+      (version (git-version "1.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url
+                "https://github.com/achilleasNP/IlluminaHumanMethylationEPICmanifest")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0v8f0hl0v8gwi61vgqw56rn5j09h95hj54rb8pzbn0znm162n4fc"))))
+      (properties `((upstream-name . "IlluminaHumanMethylationEPICmanifest")))
+      (build-system r-build-system)
+      (home-page
+       "https://github.com/achilleasNP/IlluminaHumanMethylationEPICmanifest")
+      (synopsis "Illumina Human Methylation Manifest 1.0 B5 for R and minfi")
+      (description
+       "This is a drop-in replacement for the
+@code{IlluminaHumanMethylationEPIC} package.  It utilizes a Manifest based on
+1.0B5 annotation.  As of version 0.3.0, the
+@code{IlluminaHumanMethylationEPIC} package still employs the 1.0B2 annotation
+manifest.  A corresponding annotation package,
+@code{IlluminaHumanMethylationEPICanno.ilm10b5.hg38}, is available to ensure
+proper annotation.  The decision to maintain the same name is due to
+complications in downstream processing caused by array name lookup in certain
+preprocessing options.")
+      (license license:artistic2.0))))
+
 (define-public r-illuminahumanmethylationepicanno-ilm10b5-hg38
   (let ((commit "3db06910e27f626e0cc8b335ff45cf9a4050a36a")
         (revision "1"))