summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:36 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:22 +0300
commit95c1e5121a1238c745860d7a7033bdb30c91b7cf (patch)
tree36f324743bda00c13fde8257eca0986c550049e9 /gnu
parent995443acacea93b3cec5aca364189c14aa370ea1 (diff)
downloadguix-95c1e5121a1238c745860d7a7033bdb30c91b7cf.tar.gz
gnu: Add python-stsci-stimage.
* gnu/packages/astronomy.scm (python-stsci-stimage): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index cba285816e..2f708ff652 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2098,6 +2098,30 @@ replicate core behaviour of the IRAF's
 task}.")
     (license license:bsd-3)))
 
+(define-public python-stsci-stimage
+  (package
+    (name "python-stsci-stimage")
+    (version "0.2.6")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "stsci.stimage" version))
+              (sha256
+               (base32
+                "0i7xby1gaiplvbqqv8a4f4cw1is8fwj89mix1z3bqrykqi3n24g0"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; XXX: Fix failing tests. There are errors to load test files.
+      #:tests? #f))
+    (propagated-inputs (list python-numpy))
+    (native-inputs (list python-codecov python-pytest python-pytest-cov
+                         python-setuptools-scm))
+    (home-page "https://stscistimage.readthedocs.io/en/latest/")
+    (synopsis "STScI image processing")
+    (description "This package provides an astronomical Python package with
+image processing functions: @code{xyxymatch}, @code{geomap}.")
+    (license license:bsd-3)))
+
 (define-public libnova
   (package
     (name "libnova")