summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 14:32:48 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-27 22:51:58 +0000
commit95ea5594082220c87433c0f4edd94330930628e5 (patch)
tree0e70e5dded147019e3c2a95c26d3d16f9e2b00d8 /gnu
parentfb33458ca7c68c035aad9bef0cf6b7f993b0f6c1 (diff)
downloadguix-95ea5594082220c87433c0f4edd94330930628e5.tar.gz
gnu: python-rad: Enable tests.
* gnu/packages/astronomy.scm (python-rad) [arguments] <#:test-flags>:
Enable most of the tests, ignore the one introducing cycle.
[native-inputs]: Add python-pytest.

Change-Id: Ice4bc5eb2dcaae92c44466ea1eb932544a502927
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index e1ee074ca9..bc703492f9 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4414,10 +4414,13 @@ default) to world coordinates.")
     (build-system pyproject-build-system)
     (arguments
      (list
-      ;; XXX: Tests introduce dependencies cycle, breaking it by disable them.
+      ;; Ignore tests requiring python-crds to break cycle:
       ;; python-rad -> python-roman-datamodels -> python-crds -> python-rad
-      #:tests? #f))
-    (native-inputs (list python-semantic-version python-setuptools-scm))
+      #:test-flags #~(list "--ignore=tests/test_schemas.py")))
+    (native-inputs
+     (list python-pytest
+           python-semantic-version
+           python-setuptools-scm))
     (propagated-inputs (list python-asdf python-asdf-astropy))
     (home-page "https://github.com/spacetelescope/rad")
     (synopsis "Roman Attribute Dictionary")