summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:24 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:17 +0100
commit9604015267db5ed791a84ef62ddbfa6b76ded7b6 (patch)
tree9b78aa2e5ccd26889668f09bccf025ebdc9aac10 /gnu
parente680c56d106f791e212dc3c456829683a289cbeb (diff)
downloadguix-9604015267db5ed791a84ef62ddbfa6b76ded7b6.tar.gz
gnu: Add node-serialport-parser-ready.
* gnu/packages/node-xyz.scm (node-serialport-parser-ready): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 7ce9476555..45791487af 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1152,3 +1152,26 @@ recommended high-level interface.
 Parsers are used to take raw binary data and transform them into usable
 messages.  This package provides @code{Regex}, a parser that uses a regular
 expression to split the incoming text.")))
+
+(define-public node-serialport-parser-ready
+  (package
+    (inherit node-serialport-binding-abstract)
+    (name "node-serialport-parser-ready")
+    (version "9.2.4")
+    (inputs `())
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda args
+             (chdir "packages/parser-ready"))))
+       #:tests? #f))
+    (synopsis "Node SerialPort parser to wait for specified byte sequence")
+    (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports.  The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages.  This package provides @code{Ready}, a parser that waits for a
+specified sequence of ``ready'' bytes before emitting a ready event and
+emitting data events.")))