summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2017-02-21 14:19:52 -0500
committerRicardo Wurmus <rekado@elephly.net>2017-10-10 23:09:41 +0200
commit96cb5ca1f2418871a53c6993aae6209016681ce1 (patch)
tree5a8bef0ac248417edefc2933645eb35fbae7bed7 /gnu
parent6414410d7a2306ab6712801666aba973bc18ecac (diff)
downloadguix-96cb5ca1f2418871a53c6993aae6209016681ce1.tar.gz
gnu: Add python-automat.
* gnu/packages/python.scm (python-automat, python2-automat): New variables.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5b77a25095..c9e52c9e5e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14228,6 +14228,39 @@ Python.  It is based on Parsing Expression Grammars, PEG.  With pyPEG you can
 parse many formal languages.")
     (license license:gpl2)))
 
+(define-public python-automat
+  (package
+    (name "python-automat")
+    (version "0.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "Automat" version))
+              (sha256
+               (base32
+                "1a7nsrljysfmdqmpn2apfa1gg6rfah4y9sizvns8gb08rx7d07rw"))))
+    (build-system python-build-system)
+    ;; We disable the tests because they require python-twisted, while
+    ;; python-twisted depends on python-automat.  Twisted is optional, but the
+    ;; tests fail if it is not available.  Also see
+    ;; <https://github.com/glyph/automat/issues/71>.
+    (arguments '(#:tests? #f))
+    (native-inputs
+     `(("python-m2r" ,python-m2r)
+       ("python-setuptools-scm" ,python-setuptools-scm)
+       ("python-graphviz" ,python-graphviz)))
+    (propagated-inputs
+     `(("python-six" ,python-six)
+       ("python-attrs" ,python-attrs)))
+    (home-page "https://github.com/glyph/Automat")
+    (synopsis "Self-service finite-state machines")
+    (description "Automat is a library for concise, idiomatic Python
+expression of finite-state automata (particularly deterministic finite-state
+transducers).")
+    (license license:expat)))
+
+(define-public python2-automat
+  (package-with-python2 python-automat))
+
 (define-public python-m2r
   (package
     (name "python-m2r")