summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-04-19 11:04:34 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-04-19 11:05:52 +0200
commit9719de0764b1248b0c9531c98ca05da4c7bdc91f (patch)
tree5d6c87093a39ca6c099b139866566d24c2b086e2 /gnu
parent3743e991868e825565227711db299b2100ab9cde (diff)
downloadguix-9719de0764b1248b0c9531c98ca05da4c7bdc91f.tar.gz
gnu: hamlib: Update to 4.5.5.
* gnu/packages/radio.scm (hamlib): Update to 4.5.5.
  [source]: Switch to git-fetch method.
  [arguments]: Remove 'force-bootstrap' phase.

Change-Id: Ia281f76ab0fd87b99c69eb56e004a3947455e539
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/radio.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 21f84096a4..ebe041de7f 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1491,15 +1491,16 @@ E.g.: @code{(udev-rules-service 'bladerf bladerf)}.")
 (define-public hamlib
   (package
     (name "hamlib")
-    (version "4.4")
+    (version "4.5.5")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/Hamlib/Hamlib/releases/download/"
-             version "/hamlib-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Hamlib/Hamlib")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "11r4i8gmxnb6ixpk4ns38c9xwj3qibp2v3pkhy2z0lhz0xxi1w4b"))))
+        (base32 "1z774z0g7ryamzvdm5f9b3py0lacrvmp2581jn3d581lw35hvfjw"))))
     (build-system gnu-build-system)
     (native-inputs
      (list autoconf
@@ -1523,14 +1524,7 @@ E.g.: @code{(udev-rules-service 'bladerf bladerf)}.")
          "--with-lua-binding"
          "--with-python-binding"
          "--with-tcl-binding"
-         "--with-xml-support")
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'bootstrap 'force-bootstrap
-           ;; The included configure script is misbuilt.  It will never find
-           ;; pkg-config, and hence any libraries that rely on it.  Rebuild it.
-           (lambda _
-             (delete-file "configure"))))))
+         "--with-xml-support")))
     (synopsis "Tools and API to control radios")
     (description
      "The Ham Radio Control Library (Hamlib) is a project to provide programs