summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2016-08-14 13:38:20 -0400
committerLeo Famulari <leo@famulari.name>2016-08-29 18:39:40 -0400
commit974ee2c152016406a5c44d8061b46bb7e30d3ca6 (patch)
tree9ac2b1f190feb6b9432fb760c8edc1cd36480d87 /gnu
parent5b63a8568b39c019970569773bace18fab17a157 (diff)
downloadguix-974ee2c152016406a5c44d8061b46bb7e30d3ca6.tar.gz
gnu: Add python-freezegun.
* gnu/packages/python.scm (python-freezegun, python2-freezegun): New variables.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 77bb8a4fa5..9ef588a1b6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10224,3 +10224,43 @@ List.  Forked from and using the same API as the publicsuffix package.")
       (native-inputs
        `(("python2-setuptools" ,python2-setuptools)
          ,@(package-native-inputs base))))))
+
+(define-public python-freezegun
+  (package
+    (name "python-freezegun")
+    (version "0.3.7")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "freezegun" version))
+        (sha256
+          (base32
+            "14l19x06v5jkq4rdwbmfyw4x9lrjb2300afrk21r1ash7y1y9a0w"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-nose" ,python-nose)
+       ("python-coverage" ,python-coverage)
+       ("python-dateutil-2" ,python-dateutil-2)))
+    (inputs
+     `(("python-six" ,python-six)))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+        ;; The tests are normally executed via `make test`, but the PyPi
+        ;; package does not include the Makefile.
+        (replace 'check
+          (lambda _
+            (zero? (system* "nosetests" "./tests/")))))))
+    (home-page "https://github.com/spulec/freezegun")
+    (synopsis "Test utility for mocking the datetime module")
+    (description
+      "FreezeGun is a library that allows your python tests to travel through
+time by mocking the datetime module.")
+    (license license:asl2.0)))
+
+(define-public python2-freezegun
+  (let ((base (package-with-python2 (strip-python2-variant python-freezegun))))
+    (package (inherit base)
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs base))))))