summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 21:07:35 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 23:28:16 -0500
commit975ced12d41be617c2ed85b75af6fa6afb3a60c8 (patch)
tree992471cfd9b636bedc418f58dfa39096c0c2742a /gnu
parent3d7d909c9da0545eb6b9b98bf63335a76eea037b (diff)
downloadguix-975ced12d41be617c2ed85b75af6fa6afb3a60c8.tar.gz
gnu: xf86-video-r128: Update to 6.9.2.
* gnu/packages/patches/xf86-video-r128-glibc-2.20.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/xorg.scm (xf86-video-r128): Update to 6.9.2.  Add patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/xf86-video-r128-glibc-2.20.patch17
-rw-r--r--gnu/packages/xorg.scm7
2 files changed, 21 insertions, 3 deletions
diff --git a/gnu/packages/patches/xf86-video-r128-glibc-2.20.patch b/gnu/packages/patches/xf86-video-r128-glibc-2.20.patch
new file mode 100644
index 0000000000..21a430ebc6
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-r128-glibc-2.20.patch
@@ -0,0 +1,17 @@
+Fix test compilation with exa.h in configure when using glibc 2.20.
+Inspired by a patch by Peter Hutterer <peter.hutterer@who-t.net>.
+See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
+
+--- xf86-video-r128-6.9.2/configure.~1~	2013-10-02 14:38:15.000000000 -0400
++++ xf86-video-r128-6.9.2/configure	2014-12-19 01:23:03.346735159 -0500
+@@ -18400,7 +18400,9 @@
+ 
+         SAVE_CPPFLAGS="$CPPFLAGS"
+         CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"
+-        ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default"
++        ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default
++#include <xorg-server.h>
++"
+ if test "x$ac_cv_header_exa_h" = xyes; then :
+   have_exa_h="yes"
+ else
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d337c18c82..953e764dc5 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2797,17 +2797,18 @@ kernel mode setting (KMS).")
 (define-public xf86-video-r128
   (package
     (name "xf86-video-r128")
-    (version "6.8.2")
+    (version "6.9.2")
     (source
       (origin
         (method url-fetch)
         (uri (string-append
-               "mirror://xorg/X11R7.7/src/everything/xf86-video-r128-"
+               "mirror://xorg/individual/driver/xf86-video-r128-"
                version
                ".tar.bz2"))
         (sha256
           (base32
-            "1c84x40k9qz9dnf5qs6nnjcgz7px6mpc3rbk8mj62zhp7mf16hbv"))))
+           "1q3fsc603k2yinphx5rrcl5356qkpywwz8axlw277l2231gjjbcb"))
+        (patches (list (search-patch "xf86-video-r128-glibc-2.20.patch")))))
     (build-system gnu-build-system)
     (inputs `(("mesa" ,mesa)
               ("xf86driproto" ,xf86driproto)