summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-05-21 17:57:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-21 17:57:30 +0200
commit97c2e9e4f8a6fe688912057b10a8def0eb61c570 (patch)
tree84cec5ff3612391812a2b37a1b200c2820c7e5b0 /gnu
parented5a75c73054edf22c888e285ffcfe978f945e92 (diff)
downloadguix-97c2e9e4f8a6fe688912057b10a8def0eb61c570.tar.gz
gnu: Add emacs-purescript-mode.
* gnu/packages/emacs-xyz.scm (emacs-purescript-mode): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3b261bfffa..7656c32b2e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6708,6 +6708,38 @@ linting of manifests and integration with Puppet Debugger.")
       ;; Also incorporates work covered by the Apache License, Version 2.0
       (license license:gpl3+))))
 
+(define-public emacs-purescript-mode
+  ;; Retrieved on 2021-05-18.
+  (let ((revision "0")
+        (commit "0acd1af446424ba855153161fe07a20f67dc0a89"))
+    (package
+      (name "emacs-purescript-mode")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/purescript-emacs/purescript-mode")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0rxdsmx8826az4blhnnvqrx7bjky9hwph6gkyrh33sck26xhh3g5"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-before 'install 'make-info
+             (lambda _
+               (invoke "makeinfo" "--no-split"
+                       "-o" "purescript-mode.info" "purescript-mode.texi")))))) 
+      (native-inputs
+       `(("texinfo" ,texinfo)))
+      (home-page "https://github.com/purescript-emacs/purescript-mode")
+      (synopsis "Emacs major mode and related tools for Purescript")
+      (description "This package provides an Emacs major mode for writing Purescript.")
+      (license license:gpl3+))))
+
 (define-public emacs-god-mode
   (package
     (name "emacs-god-mode")