summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-12 19:42:20 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:17 +0100
commit97db2f1302beb499f0387ddfe0eae45dc97e73d8 (patch)
tree6905b0528a988fc74aeb49334ec8146cfb89fa13 /gnu
parent4a6808226e1eb9796860aa9fa133e9c70c09e570 (diff)
downloadguix-97db2f1302beb499f0387ddfe0eae45dc97e73d8.tar.gz
gnu: python-oslo.log: Update to 4.6.1.
* gnu/packages/openstack.scm (python-oslo.log): Update to 4.6.1.
[arguments]: Override check phase.
[propagated-inputs]: Remove PYTHON-MONOTONIC.
[native-inputs]: Remove PYTHON-MOCK, PYTHON-TESTREPOSITORY, and
PYTHON-SUBUNIT.  Add PYTHON-FIXTURES and PYTHON-STESTR.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openstack.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index ae20eb6a59..e1ffc0ff23 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -456,19 +456,23 @@ in an application or library.")
 (define-public python-oslo.log
   (package
   (name "python-oslo.log")
-  (version "3.36.0")
+  (version "4.6.1")
   (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "oslo.log" version))
       (sha256
         (base32
-          "0h7hplf1h8k24v75m3mq1jlrl74x5ynyr4hwgffsg5campxnza4x"))))
+          "0dlnxjci9mpwhgfv19fy1z7xrdp8m95skrj5dr60all3pr7n22f6"))))
   (build-system python-build-system)
+  (arguments
+   '(#:phases (modify-phases %standard-phases
+                (replace 'check
+                  (lambda* (#:key tests? #:allow-other-keys)
+                    (when tests? (invoke "stestr" "run")))))))
   (propagated-inputs
    (list python-dateutil
          python-debtcollector
-         python-monotonic
          python-oslo.config
          python-oslo.context
          python-oslo.i18n
@@ -478,8 +482,7 @@ in an application or library.")
          python-pyinotify
          python-six))
   (native-inputs
-    (list python-mock python-oslotest python-subunit
-          python-testrepository python-testtools))
+    (list python-fixtures python-oslotest python-stestr python-testtools))
   (home-page "https://launchpad.net/oslo")
   (synopsis "Python logging library of the Oslo project")
   (description