summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:13:59 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:18 +0300
commit99092bd9002da40370af48beae5a8530276a792b (patch)
treed80844b542ecffaf688be92b183b15f8a8d81a4a /gnu
parentcfeefca9ae36e6c81524d9c6745c168b3bb5018b (diff)
downloadguix-99092bd9002da40370af48beae5a8530276a792b.tar.gz
gnu: Add emacs-dashboard.
* gnu/packages/emacs.scm (emacs-dashboard): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6c0dd5ce68..d71ef1fde1 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10078,3 +10078,27 @@ the previously visible buffer part after each scroll.")
       (description "@code{highlight-escape-sequences} provides an
 Emacs minor mode to escape sequences in code.")
       (license license:gpl3+))))
+
+(define-public emacs-dashboard
+  (package
+    (name "emacs-dashboard")
+    (version "1.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/rakanalh/emacs-dashboard/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1738lmbgq6gk24hcwic0qjyajr21l5xzhya4pv58dw1bhd6vxv9g"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-page-break-lines" ,emacs-page-break-lines)))
+    (arguments '(#:include '("\\.el$" "\\.txt$" "\\.png$")))
+    (home-page "https://github.com/rakanalh/emacs-dashboard")
+    (synopsis "Startup screen extracted from Spacemacs")
+    (description "This package provides an extensible Emacs dashboard, with
+sections for bookmarks, projectil projects, org-agenda and more. ")
+    (license license:gpl3+)))