summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-05-17 10:40:50 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-17 10:43:15 +0200
commit9983dee6b0b4a3ccec263dce6810f06e70b2aba3 (patch)
tree0533df26c657aebdea4f1829069c4c615bd62ab7 /gnu
parent199ae378c243e07208cfaa7fc55395850c2aa7e5 (diff)
downloadguix-9983dee6b0b4a3ccec263dce6810f06e70b2aba3.tar.gz
gnu: ecl-xmls: Disable tests.
Upstream doesn't have a test suite adapted for ECL.

* gnu/packages/lisp-xyz.scm (ecl-xmls)[arguments]: Disable tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index efd18f21a3..7c3b1ecad2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12927,7 +12927,13 @@ XML to Lisp structures or s-expressions and back.")
   (sbcl-package->cl-source-package sbcl-xmls))
 
 (define-public ecl-xmls
-  (sbcl-package->ecl-package sbcl-xmls))
+  (let ((pkg (sbcl-package->ecl-package sbcl-xmls)))
+    (package
+      (inherit pkg)
+      (arguments
+       (substitute-keyword-arguments (package-arguments pkg)
+         ;; Upstream doesn't have a test suite adapted for ECL.
+         ((#:tests? _ #f) #f))))))
 
 (define-public sbcl-geco
   (package