summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBenjamin Slade <slade@lambda-y.net>2023-12-19 12:38:27 -0600
committer宋文武 <iyzsong@member.fsf.org>2024-03-10 12:50:14 +0800
commit9b1cab90471af555c865136bfa676d72d2f9e32f (patch)
treec77d3a0e9965214ed39a61f15a61d449a01178de /gnu
parentb22e1ff117e2e3002bc3227de66f485e643137e9 (diff)
downloadguix-9b1cab90471af555c865136bfa676d72d2f9e32f.tar.gz
gnu: pdfpc: Update to 4.6.0.
* gnu/packages/pdf.scm (pdfpc): Update to 4.6.0.
[arguments]: Remove 'fix-vala-API-conflict phase.
[inputs]: Add qrencode.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Change-Id: I9dfed5b8ff4ef0dd905034ba599f9875578df232
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pdf.scm19
1 files changed, 6 insertions, 13 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index f32403b954..0a87346d8d 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -26,6 +26,7 @@
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2023 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2023 Benjamin Slade <slade@lambda-y.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -56,6 +57,7 @@
   #:use-module (guix build-system python)
   #:use-module (guix build-system qt)
   #:use-module (gnu packages)
+  #:use-module (gnu packages aidc)
   #:use-module (gnu packages audio)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages backup)
@@ -1527,7 +1529,7 @@ multiple files.")
 (define-public pdfpc
   (package
     (name "pdfpc")
-    (version "4.5.0")
+    (version "4.6.0")
     (source
      (origin
        (method git-fetch)
@@ -1536,22 +1538,13 @@ multiple files.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0bmy51w6ypz927hxwp5g7wapqvzqmsi3w32rch6i3f94kg1152ck"))))
+        (base32 "0kj84sf5hgr2v2ra6dxmxqcr173h17cpnhg9lcq36shdbdnncwg4"))))
     (build-system cmake-build-system)
-    (arguments
-     '(#:tests? #f          ; no test target
-       #:phases
-       (modify-phases %standard-phases
-         ;; This is really a bug in Vala.
-         ;; https://github.com/pdfpc/pdfpc/issues/594
-         (add-after 'unpack 'fix-vala-API-conflict
-           (lambda _
-             (substitute* "src/classes/action/movie.vala"
-               (("info.from_caps\\(caps\\)")
-                "Gst.Video.info_from_caps(out info, caps)")))))))
+    (arguments '(#:tests? #f))           ; no test target
     (inputs
      `(("cairo" ,cairo)
        ("discount" ,discount) ; libmarkdown
+       ("qrencode" ,qrencode)
        ("gtk+" ,gtk+)
        ("gstreamer" ,gstreamer)
        ("gst-plugins-base" ,gst-plugins-base)