summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:26 +0200
commit9c28a5cb38d3e88af178352559455ebcec003da2 (patch)
tree783f238974a0802c3cf5e6c30e1333e3169f8beb /gnu
parenta9f0fabe873f429d47d3a65be3325bccf938ecb2 (diff)
downloadguix-9c28a5cb38d3e88af178352559455ebcec003da2.tar.gz
gnu: Add texlive-stex.
* gnu/packages/tex.scm (texlive-stex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4cd8b645ab..c3240ed2f4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96503,6 +96503,27 @@ font better.  To achieve the borrowing, one only needs to load the package and
 specify the name of the target font via the from option.")
     (license license:lppl1.3c)))
 
+(define-public texlive-stex
+  (package
+    (name "texlive-stex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/stex/" "source/latex/stex/"
+                   "tex/latex/stex/")
+             (base32
+              "1yh991kwsm59vsylw0q1xifq18b8bdfmzf4ga0x7f0bcmwf3plab")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/stex")
+    (synopsis "Infrastructure for semantic preloading of LaTeX documents")
+    (description
+     "The sTeX package collection is a version of (La)TeX that allows to
+markup (La)TeX documents semantically without leaving the document format,
+essentially turning it into a document format for mathematical knowledge
+management (MKM).")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar