summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-29 20:10:17 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-19 07:32:29 +0200
commit9c6081c705e8221a31dc6db832fd5170b8239602 (patch)
tree6b4096608810b826695b76fd871ebc0bd00a036b /gnu
parent13cb9b302868b5a966a6ae177412c474084f4bf1 (diff)
downloadguix-9c6081c705e8221a31dc6db832fd5170b8239602.tar.gz
gnu: commencement: Add autoconf-boot0.
* gnu/packages/commencement.scm (autoconf-boot0): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 9bd0c113c2..3ccd51ac52 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -33,6 +33,7 @@
 (define-module (gnu packages commencement)
   #:use-module (gnu packages)
   #:use-module (gnu packages bootstrap)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages c)
@@ -2602,6 +2603,15 @@ memoized as a function of '%current-system'."
   (package-with-explicit-inputs %boot0-inputs
                                 %bootstrap-guile))
 
+(define autoconf-boot0
+  (with-boot0
+   (package
+     (inherit autoconf)
+     (name "autoconf-boot0")
+     (native-inputs (list m4-boot0 perl-boot0))
+     (inputs '())
+     (arguments (list #:tests? #f)))))
+
 (define gnumach-headers-boot0
   (with-boot0
    (package