summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-05-08 09:35:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-05-08 21:55:42 +0200
commit9c8bd626a1e531e65ca9d5262924ff027b8a60cf (patch)
tree760a6008ebcf45eba161b0f3d1ecd5a93e88d628 /gnu
parent965a7332201af37059bdaf97dc2ec21249bc9d32 (diff)
downloadguix-9c8bd626a1e531e65ca9d5262924ff027b8a60cf.tar.gz
gnu: gimp: Enable Python scripting support.
* gnu/packages/gimp.scm (gimp): Enable Python scripting support.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gimp.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 25a41690dd..35c55dc2f9 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -32,6 +32,7 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages photo)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages imagemagick))
 
@@ -127,10 +128,6 @@ buffers.")
                (base32
                 "0bdj0l7a94jqhjnj40m9rqaf622wj905iximivb55iy98639aanq"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:configure-flags
-       ;; We don't have pygtk which seems to be needed for this feature
-       `("--disable-python")))
     (inputs
      `(("babl" ,babl)
        ("glib" ,glib)
@@ -141,6 +138,8 @@ buffers.")
        ("exif" ,libexif)                         ;optional, EXIF + XMP support
        ("lcms" ,lcms)                            ;optional, color management
        ("librsvg" ,librsvg)                      ;optional, SVG support
+       ("python" ,python-2)                      ;optional, Python support
+       ("python2-pygtk" ,python2-pygtk)          ;optional, Python support
        ("gegl" ,gegl)))
     (native-inputs
      `(("pkg-config" ,pkg-config)