summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-10-15 03:29:13 +0200
committerCyril Roelandt <tipecaml@gmail.com>2013-12-16 02:21:09 +0100
commit9cc98f8aa6376ca28529b5b748d2a52bffb16902 (patch)
tree67753e559ca1b5f2d2cb376c3eb4ecf11705a426 /gnu
parent2748062080ded4568b79fcfc2f0f37526bfaa80c (diff)
downloadguix-9cc98f8aa6376ca28529b5b748d2a52bffb16902.tar.gz
gnu: Add gnome-desktop.
* gnu/packages/gnome.scm (gnome-desktop): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9362283d5a..609310efa5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -27,6 +27,7 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages pdf)
   #:use-module (gnu packages ghostscript)
+  #:use-module (gnu packages iso-codes)
   #:use-module (gnu packages libcanberra)
   #:use-module (gnu packages libpng)
   #:use-module (gnu packages perl)
@@ -49,6 +50,9 @@
     (build-system gnu-build-system)
     (propagated-inputs
      `(("hicolor-icon-theme" ,hicolor-icon-theme)))
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
     (inputs
      `(("glib" ,glib)
        ("gnome-doc-utils" ,gnome-doc-utils)
@@ -71,6 +75,47 @@ Desktop.  It is designed to be as simple as possible and has some unique
 features to enable users to create their discs easily and quickly.")
     (license gpl2+)))
 
+(define-public gnome-desktop
+  (package
+    (name "gnome-desktop")
+    (version "3.10.0")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnome/sources/" name "/3.10/"
+                          name "-" version ".tar.xz"))
+      (sha256
+       (base32
+        "0p5p6wvmy5zvcdnmp5h2biz7rjrcw99chq5kkwcnb68flcmkb1ry"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gdk-pixbuf" ,gdk-pixbuf)
+       ("glib" ,glib)
+       ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+       ("gtk+" ,gtk+)
+       ("iso-codes" ,iso-codes)
+       ("itstool" ,itstool)
+       ("libx11" ,libx11)
+       ("libxext" ,libxext)
+       ("libxkbfile" ,libxkbfile)
+       ("libxrandr" ,libxrandr)
+       ("xkeyboard-config" ,xkeyboard-config)))
+    (home-page "https://www.gnome.org/")
+    (synopsis
+     "libgnome-desktop, gnome-about, and desktop-wide documents")
+    (description
+     "The libgnome-desktop library provides API shared by several applications
+on the desktop, but that cannot live in the platform for various reasons. There
+is no API or ABI guarantee, although we are doing our best to provide
+stability. Documentation for the API is available with gtk-doc.
+
+The gnome-about program helps find which version of GNOME is installed.")
+    ; Some bits under the LGPL.
+    (license gpl2+)))
+
 (define-public gnome-doc-utils
   (package
     (name "gnome-doc-utils")