summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-04-30 08:44:57 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-04-30 08:44:57 +1000
commit9d177025005a2bcae50c698d0363fd4096d50157 (patch)
tree8bd36b651e2da6da05818d6e9372319ade0957a4 /gnu
parentb0e52f52b76ecc37a9b6469e6f72c4b4757979ce (diff)
downloadguix-9d177025005a2bcae50c698d0363fd4096d50157.tar.gz
gnu: ruby-hashery: Disable failing test.
* gnu/packages/ruby.scm (ruby-hashery)[arguments]: Remove failing
test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b8a6d01811..2aab8bf415 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3751,6 +3751,10 @@ Rubytest-based test frameworks.  It provides the @code{rubytest} executable.")
        (modify-phases %standard-phases
          (replace 'check
            (lambda _
+             ;; Remove known test failure documented at
+             ;; https://github.com/rubyworks/hashery/issues/25
+             (substitute* "test/case_key_hash.rb"
+               (("^      assert\\(s\\)") ""))
              (and (zero? (system* "qed"))
                   (zero? (system* "rubytest" "-Ilib" "-Itest" "test/"))))))))
     (native-inputs