summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 15:00:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 15:29:14 +0200
commit9d45783d777eda4874570f5cba29a9e4be9a0abf (patch)
tree9b32901221ad9ca50699227cc0ecf446f618e3d8 /gnu
parentc5f9e435da652179aa70f8c6c9cabdbb02cf0728 (diff)
downloadguix-9d45783d777eda4874570f5cba29a9e4be9a0abf.tar.gz
gnu: Add r-spatialexperiment.
* gnu/packages/bioconductor.scm (r-spatialexperiment): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c7f99d82b4..656bb1a9c0 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -19426,6 +19426,38 @@ operations on sparse matrices.  Currently, the optimizations are limited to
 data in the column sparse format.")
     (license license:expat)))
 
+(define-public r-spatialexperiment
+  (package
+    (name "r-spatialexperiment")
+    (version "1.10.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "SpatialExperiment" version))
+              (sha256
+               (base32
+                "18fcfyjvp9nzadlicsnz62wva8ik0z6jqg1b906avm2vk6rbxw70"))))
+    (properties `((upstream-name . "SpatialExperiment")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biocfilecache
+                             r-biocgenerics
+                             r-dropletutils
+                             r-magick
+                             r-rjson
+                             r-s4vectors
+                             r-singlecellexperiment
+                             r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/drighelli/SpatialExperiment")
+    (synopsis "S4 class for spatially resolved -omics data")
+    (description
+     "This package defines an S4 class for storing data from spatial -omics
+experiments.  The class extends SingleCellExperiment to support storage and
+retrieval of additional information from spot-based and molecule-based
+platforms, including spatial coordinates, images, and image metadata.  A
+specialized constructor function is included for data from the 10x Genomics
+Visium platform.")
+    (license license:gpl3)))
+
 (define-public r-delayedmatrixstats
   (package
     (name "r-delayedmatrixstats")