summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-17 20:57:19 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:32 +0300
commit9e4e4fcfc87dbf916c4449b8d669fd04b37b839b (patch)
tree68a9ffe4da2c72dc4135fe108314bf9dd19ca81d /gnu
parent8a8a0aee0210e11136bf52a4356615480dd30c5e (diff)
downloadguix-9e4e4fcfc87dbf916c4449b8d669fd04b37b839b.tar.gz
gnu: rust-tls-parser-0.10: Update to 0.11.0.
* gnu/packages/crates-io.scm (rust-tls-parser-0.11): New variable.
(rust-tls-parser-0.10): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 16 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c0b49932a2..a1b5bc56ea 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35074,10 +35074,10 @@ based on Rustls and Ring.")
     (description "This package provides thousand separators for numerals.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-tls-parser-0.10
+(define-public rust-tls-parser-0.11
   (package
     (name "rust-tls-parser")
-    (version "0.10.0")
+    (version "0.11.0")
     (source
      (origin
        (method url-fetch)
@@ -35086,21 +35086,27 @@ based on Rustls and Ring.")
         (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "1spgykvrxlzb059zzz1hzinc4vvkpixw9nd6p94vw3rimar5m68n"))))
+         "1q0vd41sjf6pbcygp5bqlpqrxbqdd0qsqi4sm5zbzvb4vvi0d4j0"))
+       (snippet
+        #~(begin (use-modules (guix build utils))
+                 ;; Accept newer versions of rust-clap.
+                 (substitute* "Cargo.toml"
+                   (("~2\\.33") "^2.33"))))))
     (build-system cargo-build-system)
     (arguments
      `(#:tests? #f ;; requires assets not included in crates.io tarball
        #:cargo-inputs
        (("rust-cookie-factory" ,rust-cookie-factory-0.3)
         ("rust-enum-primitive" ,rust-enum-primitive-0.1)
-        ("rust-nom" ,rust-nom-6)
-        ("rust-nom-derive" ,rust-nom-derive-0.7)
-        ("rust-phf" ,rust-phf-0.8)
-        ("rust-phf-codegen" ,rust-phf-codegen-0.8)
-        ("rust-rusticata-macros" ,rust-rusticata-macros-3))
+        ("rust-nom" ,rust-nom-7)
+        ("rust-nom-derive" ,rust-nom-derive-0.10)
+        ("rust-phf" ,rust-phf-0.10)
+        ("rust-phf-codegen" ,rust-phf-codegen-0.10)
+        ("rust-rusticata-macros" ,rust-rusticata-macros-4))
        #:cargo-development-inputs
-       (("rust-hex-literal" ,rust-hex-literal-0.3)
-        ("rust-pretty-assertions" ,rust-pretty-assertions-0.6))))
+       (("rust-clap" ,rust-clap-2)
+        ("rust-hex-literal" ,rust-hex-literal-0.3)
+        ("rust-pretty-assertions" ,rust-pretty-assertions-0.7))))
     (home-page "https://github.com/rusticata/tls-parser")
     (synopsis "Parser for the TLS protocol")
     (description "This package provides a Rust parser for the TLS protocol.")