summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorcage <cage-dev@twistfold.it>2021-03-03 16:23:46 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-04 10:20:15 +0100
commit9e9c9a3a02110fbe3551cf000b6ceb67c9888c34 (patch)
tree06bb5b777b0bf27125a811a72d9d771e2a648362 /gnu
parent88d822c5f1750edcd362632184cc2bcb331e01e2 (diff)
downloadguix-9e9c9a3a02110fbe3551cf000b6ceb67c9888c34.tar.gz
gnu: Add cl-crypto-shortcuts.
* gnu/packages/lisp-xyz.scm (cl-crypto-shortcuts, ecl-crypto-shortcuts,
  sbcl-crypto-shortcuts): New variables.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index a36254a718..386abab55e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -14959,3 +14959,36 @@ Lisp.")
 
 (define-public cl-i18n
   (sbcl-package->cl-source-package sbcl-cl-i18n))
+
+(define-public sbcl-crypto-shortcuts
+  (let ((commit "7efd22d80e867cd8c9f8f363d4fe7b51ee2dadc0")
+        (revision "1"))
+    (package
+      (name "sbcl-crypto-shortcuts")
+      (version (git-version "2.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Shinmera/crypto-shortcuts")
+               (commit commit)))
+         (file-name (git-file-name "crypto-shortcuts" version))
+         (sha256
+          (base32 "0c0m0ar04jn7qf2v8c4sivamlzki03r13rnxy8b3n27rh9r6hgin"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("cl-base64" ,sbcl-cl-base64)
+         ("flexi-stream" ,sbcl-flexi-streams)
+         ("ironclad" ,sbcl-ironclad)))
+      (synopsis "Collection of common cryptography functions")
+      (description
+       "This is a collection of common cryptography functions for Common
+Lisp.")
+      (home-page "https://shinmera.github.io/crypto-shortcuts/")
+      (license license:zlib))))
+
+(define-public ecl-crypto-shortcuts
+  (sbcl-package->ecl-package sbcl-crypto-shortcuts))
+
+(define-public cl-crypto-shortcuts
+  (sbcl-package->cl-source-package sbcl-crypto-shortcuts))