summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Sassmannshausen <alex@pompo.co>2016-07-13 23:14:03 +0200
committerAlex Sassmannshausen <alex@pompo.co>2016-08-02 16:39:08 +0200
commit9ec9e4946695d25d899e7ed2a928dcb93c6eb9fc (patch)
treeed2af4f9dadd7fef589669d9840ceff605ffbda2 /gnu
parentcf5e49cdc51c5c564c3b223e6679230ae5862213 (diff)
downloadguix-9ec9e4946695d25d899e7ed2a928dcb93c6eb9fc.tar.gz
gnu: Add perl-log-log4perl.
* gnu/packages/perl.scm (perl-log-log4perl): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a122cc4501..13c34e7112 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2989,6 +2989,29 @@ worrying about whether the application has chosen (or will ever choose) a
 logging mechanism.")
     (license (package-license perl))))
 
+(define-public perl-log-log4perl
+  (package
+    (name "perl-log-log4perl")
+    (version "1.47")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/M/MS/MSCHILLI/Log-Log4perl-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0vxraq9navx5mgf8y8g6l5rbl3dv2ml8bishka5m69hj07nxs0ch"))))
+    (build-system perl-build-system)
+    (home-page
+     "http://search.cpan.org/dist/Log-Log4perl")
+    (synopsis "Log4j implementation for Perl")
+    (description "@code{Log::Log4perl} lets you remote-control and fine-tune
+the logging behaviour of your system from the outside.  It implements the
+widely popular (Java-based) Log4j logging package in pure Perl.")
+    (license (package-license perl))))
+
 (define-public perl-log-report-optional
   (package
     (name "perl-log-report-optional")