summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-02 13:42:43 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-09-04 14:53:34 +0200
commit9f543674ff0f2f178b656597fef24e834635d60b (patch)
treeb9461c7124ec5b4d0599063d88f5a631ad7c3196 /gnu
parent8ceb7651c2aff73644a49c1d72fe8b63948f0240 (diff)
downloadguix-9f543674ff0f2f178b656597fef24e834635d60b.tar.gz
gnu: python-pyacoustid: Update to 1.2.2.
* gnu/packages/mp3.scm (python-pyacoustid) [version]: Update to 1.2.2.
[arguments]: Add phase 'chromaprint-path.
[inputs]: Add chromaprint.
[home-page]: Update.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mp3.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 9de9055e51..3555958f2a 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -645,19 +646,34 @@ FFmpeg, etc.")
 (define-public python-pyacoustid
   (package
     (name "python-pyacoustid")
-    (version "1.1.7")
+    (version "1.2.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pyacoustid" version))
        (sha256
         (base32
-         "1zan6c22ca6sjy0g9ajwjp6mkzw7jv8r3n7jzska09a6x254lf87"))))
+         "0ha15m41r8ckmanc4k9nrlb9hprvhdjxndzw40a1yj3z1b1xjyf2"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chromaprint-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "chromaprint.py"
+               (("libchromaprint.so.1")
+                (string-append (assoc-ref inputs "chromaprint")
+                               "/lib/libchromaprint.so.1")))
+             (substitute* "acoustid.py"
+               (("'fpcalc'")
+                (string-append "'" (assoc-ref inputs "chromaprint")
+                               "/bin/fpcalc'")))
+             #t)))))
+    (inputs `(("chromaprint" ,chromaprint)))
     (propagated-inputs
      `(("python-audioread" ,python-audioread)
        ("python-requests" ,python-requests)))
-    (home-page "https://github.com/sampsyo/pyacoustid")
+    (home-page "https://github.com/beetbox/pyacoustid")
     (synopsis "Bindings for Chromaprint acoustic fingerprinting")
     (description
      "This package provides bindings for the Chromaprint acoustic