summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-03 12:03:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-03 12:31:18 +0200
commit9f6feeca3a8382f27245fd2367ee6e4f35d29373 (patch)
treee4f4501984ac440ee8f6d715b9c80487f6a0925c /gnu
parent1de41d5a1f789626c6fe9987cd77888c76607d54 (diff)
downloadguix-9f6feeca3a8382f27245fd2367ee6e4f35d29373.tar.gz
gnu: emacs-substitute: Update to 0.2.0.
* gnu/packages/emacs-xyz.scm (emacs-substitute): Update to 0.2.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4b480ce7ef..13acd89fcd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9384,24 +9384,23 @@ comparing characters, removing cursors, and more.")
       (license license:bsd-2))))
 
 (define-public emacs-substitute
-  (let ((commit "b81bb7789847f3d1645a60422fa080c48b93dd47")) ;version bump
-    (package
-      (name "emacs-substitute")
-      (version "0.1.8")
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://git.sr.ht/~protesilaos/substitute")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0s1lgpwmdjz17rd4r6qp41agmpqwa9976v1pb55p648zjh0p2vlz"))))
-      (build-system emacs-build-system)
-      (home-page "https://git.sr.ht/~protesilaos/substitute")
-      (synopsis "Efficiently replace targets in the buffer or context")
-      (description
-       "Substitute is a set of commands that perform text replacement (i)
+  (package
+    (name "emacs-substitute")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~protesilaos/substitute")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1qb2nqwy870jh66iv46bx63mp0hg7ds79259m9l783h2cr74mqjx"))))
+    (build-system emacs-build-system)
+    (home-page "https://git.sr.ht/~protesilaos/substitute")
+    (synopsis "Efficiently replace targets in the buffer or context")
+    (description
+     "Substitute is a set of commands that perform text replacement (i)
 throughout the buffer, (ii) limited to the current definition (per
 narrow-to-defun), (iii) from point to the end of the buffer, and (iv) from
 point to the beginning of the buffer.
@@ -9409,7 +9408,7 @@ point to the beginning of the buffer.
 These substitutions are meant to be as quick as possible and, as such, differ
 from the standard @code{query-replace} tool.  The provided commands prompt for
 substitute text and perform the substitution outright.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-typo
   (package