summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-12 17:36:02 +0100
committerMarius Bakke <marius@gnu.org>2022-12-12 20:23:31 +0100
commit9fc171b62a4992415803aec76fdb9c3bf9133f75 (patch)
tree93f09125e4a956e33e22528e240021bddd371c9b /gnu
parenta2c6cc43548bd88871772cbc17bae55da9138cb2 (diff)
downloadguix-9fc171b62a4992415803aec76fdb9c3bf9133f75.tar.gz
gnu: f2fs-tools: Remove obsolete phase.
* gnu/packages/linux.scm (f2fs-tools)[arguments]: Remove.
(f2fs-tools-1.7)[arguments]: Add #:phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4113e8e981..08e6d855eb 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5947,15 +5947,6 @@ obviously it can be shared with files outside our set).")
                (base32
                 "1ffws8pbpzp9730v0wy5xjas698lnbd2p7wpr2gl4mx45rsay9a5"))))
     (build-system gnu-build-system)
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'install-headers
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (out-include (string-append out "/include")))
-               (install-file "include/f2fs_fs.h" out-include)
-               (install-file "mkfs/f2fs_format_utils.h" out-include)))))))
     (native-inputs
      (list autoconf automake libtool pkg-config))
     (inputs
@@ -5988,9 +5979,15 @@ disks and SD cards.  This package provides the userland utilities.")
     (inputs
      (list `(,util-linux "lib") libselinux))
     (arguments
-     (substitute-keyword-arguments (package-arguments f2fs-tools)
-       ((#:configure-flags _ #~'())
-        #~'("CFLAGS=-fcommon"))))))
+     '(#:configure-flags '("CFLAGS=-fcommon")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'install-headers
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (out-include (string-append out "/include")))
+               (install-file "include/f2fs_fs.h" out-include)
+               (install-file "mkfs/f2fs_format_utils.h" out-include)))))))))
 
 (define-public f2fs-tools/static
   (static-package