summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-06 22:13:51 +0200
committerMarius Bakke <marius@gnu.org>2021-06-13 01:00:46 +0200
commita0286041d93215c85dd770e5b41ac5f1a294dfc4 (patch)
tree2890d1961dbf2b01f1a1b81ec8dd6399a2aec440 /gnu
parent276626ce8bebd8ee7643691d883a9aea069311d0 (diff)
downloadguix-a0286041d93215c85dd770e5b41ac5f1a294dfc4.tar.gz
gnu: expat: Remove replacement.
* gnu/packages/xml.scm (expat): Update to 2.4.1.
[replacement]: Remove.
(expat-2.4.1): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm23
1 files changed, 2 insertions, 21 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index c01d9f4dce..78daa6c10c 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -120,8 +120,7 @@ the entire document.")
 (define-public expat
   (package
     (name "expat")
-    (replacement expat-2.4.1)
-    (version "2.3.0")
+    (version "2.4.1")
     (source (let ((dot->underscore (lambda (c) (if (char=? #\. c) #\_ c))))
               (origin
                 (method url-fetch)
@@ -133,7 +132,7 @@ the entire document.")
                             "/expat-" version ".tar.xz")))
                 (sha256
                  (base32
-                  "1ab7fkab4wbj53xqsx2a4h5m310ak9abczjh0a2ymg73nsclz8ya")))))
+                  "0spvyb9d3hijs4ys3x64cfmilsynl8kv6clfahv8d4lvp86js0yg")))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("--disable-static")))
@@ -145,24 +144,6 @@ stream-oriented parser in which an application registers handlers for
 things the parser might find in the XML document (like start tags).")
     (license license:expat)))
 
-;; Replacement package to fix CVE-2013-0340.
-(define expat-2.4.1
-  (package
-    (inherit expat)
-    (version "2.4.1")
-    (source (let ((dot->underscore (lambda (c) (if (char=? #\. c) #\_ c))))
-              (origin
-                (method url-fetch)
-                (uri (list (string-append "mirror://sourceforge/expat/expat/"
-                                          version "/expat-" version ".tar.xz")
-                           (string-append
-                            "https://github.com/libexpat/libexpat/releases/download/R_"
-                            (string-map dot->underscore version)
-                            "/expat-" version ".tar.xz")))
-                (sha256
-                 (base32
-                  "0spvyb9d3hijs4ys3x64cfmilsynl8kv6clfahv8d4lvp86js0yg")))))))
-
 (define-public libebml
   (package
     (name "libebml")