summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-31 15:36:22 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-03 14:31:51 +0200
commita11ee478a684e7a18f1a3eb51e3164645129af75 (patch)
tree8364ea783d71d039a9be2593d2b87d62795cb148 /gnu
parent9ca731baf196d41cfbbd07cb85d8fd46b7fa4b40 (diff)
downloadguix-a11ee478a684e7a18f1a3eb51e3164645129af75.tar.gz
gnu: Add r-scales.
* gnu/packages/statistics.scm (r-scales): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 5b662a1d4e..b10ebdccd4 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -429,3 +429,30 @@ the input of another.")
      "Reshape2 is an R library to flexibly restructure and aggregate data
 using just two functions: melt and dcast (or acast).")
     (license license:expat)))
+
+(define-public r-scales
+  (package
+    (name "r-scales")
+    (version "0.2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cran/src/contrib/scales_"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "12xrmn1vh64dl46bq7n7pa427aicb2ifjrby9in3m32nyvir0kac"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-dichromat" ,r-dichromat)
+       ("r-labeling" ,r-labeling)
+       ("r-munsell" ,r-munsell)
+       ("r-plyr" ,r-plyr)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/hadley/scales")
+    (synopsis "Scale functions for visualization")
+    (description
+     "This package provides graphical scales that map data to aesthetics, and
+provides methods for automatically determining breaks and labels for axes and
+legends.")
+    (license license:expat)))