summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 15:41:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:31 +0200
commita209a8c0607b0b019e098fbf7001a5b4d9903434 (patch)
treea816cacd235990b595498a1b3a23b9d4e17d4da4 /gnu
parentc44828801158c86235e3b6e17613af9a148c1977 (diff)
downloadguix-a209a8c0607b0b019e098fbf7001a5b4d9903434.tar.gz
gnu: Add texlive-gfdl.
* gnu/packages/tex.scm (texlive-gfdl): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 845ec62774..56ef99a429 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14589,6 +14589,29 @@ presentation standards required by the @emph{Cahiers du GERAD} series.")
 of the History Faculty of the University of Freiburg (Germany).")
     (license license:lppl)))
 
+(define-public texlive-gfdl
+  (package
+    (name "texlive-gfdl")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/gfdl/" "source/latex/gfdl/"
+                   "tex/latex/gfdl/")
+             (base32
+              "1yiyhks3097sz686sar1jnkska669hp7v2sv1fm7n0d4j00zm816")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/gfdl")
+    (synopsis "Support for using GFDL in LaTeX")
+    (description
+     "The @acronym{GFDL, GNU Free Documentation License} is a popular license
+used for programming manuals, documentations and various other textual works
+too, but using this license with LaTeX is not very convenient.  This package
+aims to help users in easily using the license without violating any rules of
+the license.  With a handful of commands, users can rest assured that their
+document will be perfectly licensed under GFDL.")
+    (license (list license:gpl3+ license:fdl1.3+))))
+
 (define-public texlive-gfsartemisia
   (package
     (name "texlive-gfsartemisia")