summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-09 21:49:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-09 22:00:32 +0300
commita2130bcf09af41e4f3e017a8b6118007a30fd2f2 (patch)
treef76c825f24d816690da262db429cda96f664fa63 /gnu
parent1a23c0a0c7a865e1d8c7443e714e1214fc2e2842 (diff)
downloadguix-a2130bcf09af41e4f3e017a8b6118007a30fd2f2.tar.gz
gnu: git-annex: Update inputs.
* gnu/packages/haskell-apps.scm (git-annex)[inputs]: Add
ghc-ansi-terminal, ghc-attoparsec, ghc-conduit, ghc-connection,
ghc-http-client-tls, ghc-microlens, ghc-network-bsd, ghc-network-uri,
ghc-transformers, ghc-unliftio-core, ghc-vector. Remove ghc-esqueleto,
ghc-hslogger.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-apps.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index f7ca3b324f..5579ef58ea 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -11,7 +11,7 @@
 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
 ;;; Copyright © 2019, 2020 Kyle Meyer <kyle@kyleam.com>
 ;;; Copyright © 2015 John Soo <jsoo1@asu.edu>
-;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;; Copyright © 2020 Brian Leung <bkleung89@gmail.com>
@@ -404,12 +404,16 @@ to @code{cabal repl}).")
     (inputs
      (list curl
            ghc-aeson
+           ghc-ansi-terminal
            ghc-async
+           ghc-attoparsec
            ghc-aws
            ghc-bloomfilter
            ghc-byteable
            ghc-case-insensitive
            ghc-concurrent-output
+           ghc-conduit
+           ghc-connection
            ghc-crypto-api
            ghc-cryptonite
            ghc-data-default
@@ -417,26 +421,28 @@ to @code{cabal repl}).")
            ghc-disk-free-space
            ghc-dlist
            ghc-edit-distance
-           ghc-esqueleto
            ghc-exceptions
            ghc-feed
            ghc-filepath-bytestring
            ghc-free
            ghc-hinotify
-           ghc-hslogger
            ghc-http-client
+           ghc-http-client-tls
            ghc-http-client-restricted
            ghc-http-conduit
            ghc-http-types
            ghc-ifelse
            ghc-magic
            ghc-memory
+           ghc-microlens
            ghc-monad-control
            ghc-monad-logger
            ghc-mountpoints
            ghc-network
+           ghc-network-bsd
            ghc-network-info
            ghc-network-multicast
+           ghc-network-uri
            ghc-old-locale
            ghc-optparse-applicative
            ghc-persistent
@@ -454,10 +460,13 @@ to @code{cabal repl}).")
            ghc-stm-chans
            ghc-tagsoup
            ghc-torrent
+           ghc-transformers
            ghc-unix-compat
+           ghc-unliftio-core
            ghc-unordered-containers
            ghc-utf8-string
            ghc-uuid
+           ghc-vector
            git
            rsync))
     (native-inputs