summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-28 16:08:07 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-14 21:38:01 +0000
commita229acffb7a68da87a8a4bb1cfc53328ce3187a2 (patch)
tree6d78a48e8cde81a4d1b6d2007d0e0268c05baf3d /gnu
parent52b015a93c0e312333fe8c5000a3f8c199118dd1 (diff)
downloadguix-a229acffb7a68da87a8a4bb1cfc53328ce3187a2.tar.gz
gnu: Add ruby-websocket-driver.
* gnu/packages/ruby.scm (ruby-websocket-driver): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0634c6ddf6..e9c0187639 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5512,6 +5512,30 @@ checking for the right Ruby version in software.")
     (home-page "https://github.com/janlelis/ruby_version")
     (license license:expat)))
 
+(define-public ruby-websocket-driver
+  (package
+   (name "ruby-websocket-driver")
+   (version "0.7.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (rubygems-uri "websocket-driver" version))
+     (sha256
+      (base32
+       "1551k3fs3kkb3ghqfj3n5lps0ikb9pyrdnzmvgfdxy8574n4g1dn"))))
+   (build-system ruby-build-system)
+   (arguments
+    '(;; No included tests
+      #:tests? #f))
+   (propagated-inputs
+    `(("ruby-websocket-extensions" ,ruby-websocket-extensions)))
+   (synopsis "WebSocket protocol handler with pluggable I/O")
+   (description
+    "@code{websocket-driver} provides a complete implementation of the
+WebSocket protocols that can be hooked up to any TCP library")
+   (home-page "https://github.com/faye/websocket-driver-ruby")
+   (license license:expat)))
+
 (define-public ruby-websocket-extensions
   (package
     (name "ruby-websocket-extensions")