summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:00:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:45 +0200
commita27626ce282064d37b2b8e362fd799ec87bf4368 (patch)
treeae3455c649dc5551b41d57f494ee4b49580a0f00 /gnu
parent43b75f41cbfa0bdd05673705c8b27ae382c1c22e (diff)
downloadguix-a27626ce282064d37b2b8e362fd799ec87bf4368.tar.gz
gnu: Add texlive-rotpages.
* gnu/packages/tex.scm (texlive-rotpages): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9845962354..85f86867b1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94267,6 +94267,27 @@ a bridge between the two packages and extends the commands from the float
 package to define rotated versions of the new floats, too.")
     (license license:lppl)))
 
+(define-public texlive-rotpages
+  (package
+    (name "texlive-rotpages")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/rotpages/" "tex/latex/rotpages/")
+             (base32
+              "1lr7xj6z1l0prl787sfw3l5z4m4gp46n840zc84a51rm05vghjp7")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/rotpages")
+    (synopsis "Typeset sets of pages upside-down and backwards")
+    (description
+     "The @code{rotpages} package allows you to format documents where small sets
+of pages are rotated by 180 degrees and rearranged, so that they can be read
+by turning the printed copy upside-down.  It was developed for collecting
+exercises and solutions: using the package, you can print the exercise text
+normally and the solutions rotated.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar