summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:06 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-20 08:54:11 -0500
commita2af6352e3bb4c009dcd16d596586c804fcf79be (patch)
tree21af0662c88f04f2f5b1125f680f8cc70c8e43be /gnu
parent9290e943cfa03e7b671b7de5165e5f21225a1c8f (diff)
downloadguix-a2af6352e3bb4c009dcd16d596586c804fcf79be.tar.gz
gnu: Add go-github-com-ssor-bom.
* gnu/packages/golang.scm (go-github-com-ssor-bom): New variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 03481d99e9..89feb19846 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10614,6 +10614,29 @@ config, data and cache directories according to the XDG Base Directory
 Specification.")
     (license license:expat)))
 
+(define-public go-github-com-ssor-bom
+  (package
+    (name "go-github-com-ssor-bom")
+    (version "0.0.0-20170718123548-6386211fdfcf")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ssor/bom")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "09g5496ifwqxqclh2iw58plcwcz0sczlnxwqxzwmnl4shdl371ld"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/ssor/bom"))
+    (home-page "https://github.com/ssor/bom")
+    (synopsis "Cleaning BOMs in Go")
+    (description
+     "The bom package provides small tools for cleaning BOMs from a byte
+array or reader.")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar