summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 15:27:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:50 +0100
commita536c7c9ad78ce95fb8dad61114c40c57b3c0be8 (patch)
tree57bbada816ca0d0fdd63054bcb3ef3e7131fc29d /gnu
parent1ab5160434fcdb7bfb8b56d5277c18c2cf44ef10 (diff)
downloadguix-a536c7c9ad78ce95fb8dad61114c40c57b3c0be8.tar.gz
gnu: Add r-rmpfr.
* gnu/packages/cran.scm (r-rmpfr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 930a89245b..f305f2be80 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9460,3 +9460,29 @@ rationals, prime number tests, matrix computation), \"arithmetic without
 limitations\" using the GNU Multiple Precision library.")
     ;; Any version of the GPL.
     (license license:gpl3+)))
+
+(define-public r-rmpfr
+  (package
+    (name "r-rmpfr")
+    (version "0.7-1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "Rmpfr" version))
+       (sha256
+        (base32
+         "0172px5ryi7i0gyyin9z2bzif8vnj292gk0s1w5p3c12g9hj2c4v"))))
+    (properties `((upstream-name . "Rmpfr")))
+    (build-system r-build-system)
+    (inputs
+     `(("mpfr" ,mpfr)))
+    (propagated-inputs
+     `(("r-gmp" ,r-gmp)))
+    (home-page "http://rmpfr.r-forge.r-project.org/")
+    (synopsis "R bindings to the MPFR library")
+    (description
+     "This package supports arithmetic (via S4 classes and methods) for
+arbitrary precision floating point numbers, including transcendental
+functions.  To this end, the package interfaces with the @dfn{Multiple
+Precision Floating-Point Reliable} (MPFR) library.")
+    (license license:gpl2+)))