summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-08-05 00:11:41 +0200
committerLudovic Courtès <ludo@gnu.org>2017-08-05 00:31:26 +0200
commita56bf101c603aac3c7e2fc47bd8bd025f2ed44a6 (patch)
tree1458ec8e51c4e58ed6b0dfde0ed1a18f7ed0cdf6 /gnu
parent240d3ceff78464a160d099adfb6463f4f17d6616 (diff)
downloadguix-a56bf101c603aac3c7e2fc47bd8bd025f2ed44a6.tar.gz
gnu: perl: Work around more "dotless @INC" build issues.
* gnu/packages/web.scm (perl-www-curl)[arguments]: Add 'set-search-path'
phase.
* gnu/packages/bioinformatics.scm (ngs-sdk)[arguments]: Augment
'configure' phase to set PERL5LIB.
* gnu/packages/image.scm (steghide)[arguments]: Add #:phases argument.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm4
-rw-r--r--gnu/packages/image.scm11
-rw-r--r--gnu/packages/web.scm11
3 files changed, 24 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6bbbe33784..2b4b400c19 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4680,6 +4680,10 @@ Roche 454, Ion Torrent and Pacific BioSciences SMRT.")
         'configure
         (lambda* (#:key outputs #:allow-other-keys)
           (let ((out (assoc-ref outputs "out")))
+            ;; Allow 'konfigure.perl' to find 'package.prl'.
+            (setenv "PERL5LIB"
+                    (string-append ".:" (getenv "PERL5LIB")))
+
             ;; The 'configure' script doesn't recognize things like
             ;; '--enable-fast-install'.
             (zero? (system* "./configure"
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 1b230b5700..5bc9a77174 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -986,7 +986,16 @@ differences in file encoding, image quality, and other small variations.")
        ("libjpeg" ,libjpeg)
        ("zlib" ,zlib)))
     (arguments
-     `(#:make-flags '("CXXFLAGS=-fpermissive"))) ;required for MHashPP.cc
+     `(#:make-flags '("CXXFLAGS=-fpermissive")    ;required for MHashPP.cc
+
+       #:phases (modify-phases %standard-phases
+                  (add-before 'configure 'set-perl-search-path
+                    (lambda _
+                      ;; Work around "dotless @INC" build failure.
+                      (setenv "PERL5LIB"
+                              (string-append (getcwd) "/tests:"
+                                             (getenv "PERL5LIB")))
+                      #t)))))
     (home-page "http://steghide.sourceforge.net")
     (synopsis "Image and audio steganography")
     (description
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 695b7a3b54..096d05c167 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3249,7 +3249,16 @@ RFC 6570.")
                 "1fmp9aib1kaps9vhs4dwxn7b15kgnlz9f714bxvqsd1j1q8spzsj"))))
     (build-system perl-build-system)
     (arguments
-     '(#:tests? #f))                        ;XXX: tests require network access
+     '(#:tests? #f                          ;XXX: tests require network access
+
+       #:phases (modify-phases %standard-phases
+                   (add-before 'configure 'set-search-path
+                     (lambda _
+                       ;; Work around "dotless @INC" build failure.
+                       (setenv "PERL5LIB"
+                               (string-append (getcwd) ":"
+                                              (getenv "PERL5LIB")))
+                       #t)))))
     (native-inputs
      `(("perl-module-install" ,perl-module-install)))
     (inputs `(("curl" ,curl)))