summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-03 11:16:21 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:37 +0200
commita56e1a84ae11ee56ebcfd5ccee11758c134e1e6b (patch)
treea59c9178c501de5dc699db947e85e7686fbeef49 /gnu
parent71a77016c09f937c4aad23a6182927bf66f440c2 (diff)
downloadguix-a56e1a84ae11ee56ebcfd5ccee11758c134e1e6b.tar.gz
gnu: Add svt-hevc.
* gnu/packages/video.scm (svt-hevc): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 940670fd52..80a2b3319f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -172,6 +172,34 @@
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public svt-hevc
+  (package
+    (name "svt-hevc")
+    (version "1.4.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/OpenVisualCloud/SVT-HEVC.git")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1sqh3dciqm2p1b66kngcpxqy5fx3ramxlxy8gfcbdwn2i3rsqhs7"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f)) ; Test script is stand-alone
+    (native-inputs
+     `(("yasm" ,yasm)))
+    (synopsis "SVT HEVC encoder")
+    (description "Scalable Video Technology (SVT) is a software-based video
+coding technology that is highly optimized for Intel's Xeon processors.  Using
+the SVT-HEVC encoder, it is possible to spread video encoding processing across
+multiple Intel's Xeon processors to achieve a real advantage of processing
+efficiency.")
+    (home-page "https://01.org/svt")
+    (license (license:non-copyleft "file:///LICENSE.md"))))
+
 (define-public mediasdk
   (package
     (name "mediasdk")