summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2021-04-15 14:09:26 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2021-04-15 14:12:10 +0100
commita5bbd38fd131282e928144e869dcdf1e09259085 (patch)
treecda6c288b165409220994d5f251c253cc73c1968 /gnu
parent27396a13c848629366fdcc5b17ea22c43d6589fe (diff)
downloadguix-a5bbd38fd131282e928144e869dcdf1e09259085.tar.gz
gnu: Add texlive-kastrup.
* gnu/packages/tex.scm: New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 305d40178a..bcb7f168fb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8055,3 +8055,34 @@ is known in the LaTeX scheme of things as @emph{LY1} encoding.  The
 basic Adobe Type 1 fonts (Times, Helvetica and Courier) in LaTeX using
 LY1 encoding.")
     (license license:lppl1.0+)))
+
+(define-public texlive-kastrup
+  (package
+    (name "texlive-kastrup")
+    (version (number->string %texlive-revision))
+    (source
+     (origin
+       (method svn-fetch)
+       (uri (texlive-ref "generic" "kastrup"))
+       (file-name (string-append name "-" version "-checkout"))
+       (sha256
+        (base32
+         "1kkshc48brkq2nx3rlbv78a2130izykbf33ri1q2shqr8pjfmmq8"))))
+    (build-system texlive-build-system)
+    (arguments
+     '(#:tex-directory "generic/kastrup"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'remove-generated-file
+           (lambda _
+             (delete-file "binhex.drv")
+             #t)))))
+    (home-page "http://www.ctan.org/pkg/binhex")
+    (synopsis "Convert numbers into binary, octal and hexadecimal")
+    (description "The @code{kastrup} package provides the
+@emph{binhex.tex} file.  This file provides expandable macros for both
+fixed-width and minimum-width numbers to bases 2, 4, 8 and 16.  All
+constructs TeX accepts as arguments to its @code{\\number} primitive
+are valid as arguments for the macros.  The package may be used under
+LaTeX and plain TeX.")
+    (license (license:fsf-free "file:/binhex.dtx"))))