summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 21:09:43 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 23:28:17 -0500
commita5bea0a7308023bffa6610ea04aeba2f6ec3cbc7 (patch)
tree2399ff4c38f25fc560af2928fd9e3f55bcb71dca /gnu
parent1a7830457215076923e48288ef23745a7132fb15 (diff)
downloadguix-a5bea0a7308023bffa6610ea04aeba2f6ec3cbc7.tar.gz
gnu: xf86-video-siliconmotion: Update to 1.7.7.
* gnu/packages/patches/xf86-video-siliconmotion-remove-mibstore.patch:
  New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/xorg.scm (xf86-video-siliconmotion): Update to 1.7.7.
  Add patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/xf86-video-siliconmotion-remove-mibstore.patch16
-rw-r--r--gnu/packages/xorg.scm9
2 files changed, 22 insertions, 3 deletions
diff --git a/gnu/packages/patches/xf86-video-siliconmotion-remove-mibstore.patch b/gnu/packages/patches/xf86-video-siliconmotion-remove-mibstore.patch
new file mode 100644
index 0000000000..5fd9100609
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-siliconmotion-remove-mibstore.patch
@@ -0,0 +1,16 @@
+Removes references to mibstore.h and miInitializeBackingStore, which
+have been removed from xorg-server.  Zack Rusin <zackr@vmware.com>
+wrote: "It was a noop for at least 5 years and it has been removed."
+See: http://patches.openembedded.org/patch/46133/
+
+--- xf86-video-siliconmotion-1.7.7/src/smi_driver.c.~1~	2012-07-17 00:53:21.000000000 -0400
++++ xf86-video-siliconmotion-1.7.7/src/smi_driver.c	2014-12-19 01:30:16.708884086 -0500
+@@ -1750,8 +1750,6 @@
+ 		   "Done writing mode.  Register dump:\n");
+     SMI_PrintRegs(pScrn);
+ 
+-    miInitializeBackingStore(pScreen);
+-
+ #ifdef HAVE_XMODES
+     xf86DiDGAInit(pScreen, (unsigned long)(pSmi->FBBase + pScrn->fbOffset));
+ #endif
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 230d41fc99..5470000a99 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2848,17 +2848,20 @@ kernel mode setting (KMS).")
 (define-public xf86-video-siliconmotion
   (package
     (name "xf86-video-siliconmotion")
-    (version "1.7.6")
+    (version "1.7.7")
     (source
       (origin
         (method url-fetch)
         (uri (string-append
-               "mirror://xorg/X11R7.7/src/everything/xf86-video-siliconmotion-"
+               "mirror://xorg/individual/driver/xf86-video-siliconmotion-"
                version
                ".tar.bz2"))
         (sha256
           (base32
-            "01sdl6ky1vmvmfgx2d44i35rqafi0z07xdy40cvindcr2k91p7x5"))))
+           "1an321kqvsxq0z35acwl99lc8hpdkayw0q180744ypcl8ffvbf47"))
+        (patches
+         (list
+          (search-patch "xf86-video-siliconmotion-remove-mibstore.patch")))))
     (build-system gnu-build-system)
     (inputs `(("xorg-server" ,xorg-server)))
     (native-inputs `(("pkg-config" ,pkg-config)))