summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-05 22:16:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-05 22:45:41 +0200
commita72d343aea5827f4c8491751ea2767f067005395 (patch)
tree0237c2db36c8409a9b40d0858c18711582e3585f /gnu
parente5c081291eeb16afea28891e5b2199daa93a0ba3 (diff)
downloadguix-a72d343aea5827f4c8491751ea2767f067005395.tar.gz
gnu: Add texlive-pst-text.
* gnu/packages/tex.scm (texlive-pst-text): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 915f514944..0fdd970dde 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7144,3 +7144,25 @@ features, including a wide variety of graphics (picture drawing) macros, with
 a flexible interface and with colour support.  There are macros for colouring
 or shading the cells of tables.")
       (license license:lppl1.3+))))
+
+(define-public texlive-pst-text
+  (let ((template (simple-texlive-package
+                   "texlive-pst-text"
+                   (list "/doc/generic/pst-text/"
+                         "/source/generic/pst-text/Makefile"
+                         "/dvips/pst-text/pst-text.pro"
+                         "/tex/generic/pst-text/"
+                         "/tex/latex/pst-text/")
+                   (base32
+                    "0s2bbkdfy0shqrrkjflrn0x0pnvxzbdc38pjbdfw46wnmnxrnasm")
+                   #:trivial? #t)))
+    (package
+      (inherit template)
+      (propagated-inputs
+       `(("texlive-pstricks" ,texlive-pstricks)))
+      (home-page "http://www.ctan.org/pkg/pst-text")
+      (synopsis "Text and character manipulation in PSTricks")
+      (description "Pst-text is a PSTricks based package for plotting text along
+a different path and manipulating characters.  It includes the functionality
+of the old package @code{pst-char}.")
+      (license license:lppl))))