summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 12:10:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:08 +0200
commita80e37dd5aec2c02ccf92618e0d221be00fbf1c5 (patch)
treeae40c0df9654a8fad4773962823e46f59bf477c3 /gnu
parent5c4950baed79b6fcd19ccaf564b74c5cdd98ce5e (diff)
downloadguix-a80e37dd5aec2c02ccf92618e0d221be00fbf1c5.tar.gz
gnu: Add texlive-guide-to-latex.
* gnu/packages/tex.scm (texlive-guide-to-latex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cd75a32d18..477d54d29d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4024,6 +4024,25 @@ Afterwards all necessary dimensions are calculated and the scheme is drawn.
 Currently two steps of symmetry reduction are supported.")
     (license license:lppl)))
 
+(define-public texlive-guide-to-latex
+  (package
+    (name "texlive-guide-to-latex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/guide-to-latex/")
+             (base32
+              "1wc5pclv27af2zr6kjjahjzxxlab31d8970jvxr9lxiqllvkxyab")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/guide-to-latex")
+    (synopsis "Examples and more from @emph{Guide to LaTeX}, by Kopka and Daly")
+    (description
+     "This package contains material presented in the book @emph{Guide to LaTeX},
+4th edition, by Helmut Kopka and Patrick W. Daly as code, sample figures,
+processed files, as well as solutions to the exercices.")
+    (license license:lppl1.3c+)))
+
 (define-public texlive-helmholtz-ellis-ji-notation
   (package
     (name "texlive-helmholtz-ellis-ji-notation")