summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-04-12 19:09:40 +0200
committerJulien Lepiller <julien@lepiller.eu>2023-04-12 21:53:05 +0200
commita957171bc41e98e29674f99cf3dd2940ff45a0d3 (patch)
treef784fee6eeff3c12906c896d0ad0919d51ea9ff3 /gnu
parent8557eb9ffb909d5df8aba5ca1c444f23f083d7e9 (diff)
downloadguix-a957171bc41e98e29674f99cf3dd2940ff45a0d3.tar.gz
gnu: ocaml-mdx: Fix tests.
* gnu/packages/ocaml.scm (ocaml-mdx)[arguments]: Substitue obsolete 'egrep' by
'grep -E'.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f1c4e35044..b462d315e1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9230,7 +9230,12 @@ variants.")
                             "test/bin/mdx-test/misc/no-such-prelude/test.expected")
                (("`") "'")
                (("COMMAND") "[COMMAND]")
-               (("\\.\\.\\.") "…")))))))
+               (("\\.\\.\\.") "…"))))
+         (add-after 'fix-test-format 'fix-egrep
+           (lambda _
+             ;; egrep is obsolescent; using grep -E
+             (substitute* "test/bin/mdx-test/expect/padding/test-case.md"
+               (("egrep") "grep -E")))))))
     (propagated-inputs
      (list ocaml-fmt
            ocaml-astring